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Getting Started

Overview
MiSync Personal for Beams is a tool that allows you to
synchronize contacts between Outlook and Beams CRM.
You can synchronize Leads based on how many days old is
the Leads.
Once you synchronize data, MiSync Personal for Beams
stores a link between Beams CRM and Outlook so that
changes made to leads in one system are reflected in the
other.

What’s New
New installer for x64.

System Requirements
Microsoft SQL Server or MSDE
Beams CRM
Microsoft Outlook 2003/2007/2010
Microsoft Exchange 2007/2010
Microsoft Exchange Web Services
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Technical Support
For technical support, contact:
Metisc Computer Services
www.metisc.com.au
support@metisc.com.au

Installing MiSync Personal for Beams
Run the installation program on the computer on which you
wish to use MiSync. Click Next > to begin the
installation.

Choose the Source System that will be used for this
MiSync Personal. Then click Install to continue the
installation.

6  Getting Started

MiSync Personal User Guide for CRM

MiSync is now ready to be installed. If you are happy with
your installation settings, click Install to commence the
installation.

Once installation is complete, click
installation process.
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Finish

to end the
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There should now be a shortcut to MiSync Personal placed
on your desktop.
►

To un-install, see “Installation Notes” section in the
appendices.

Running MiSync Personal for Beams for the First Time
Enter all the required server, organization and user data.
Click the OK button to login
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Connection Name – enter the connection name.
Server Name – enter the SQL Server server name.
Database Name – enter the SQL Server database name.
Use Windows Authentication – check if the SQL Server
login is using windows authentication.
User Name – enter the username you use to get into the
SQL Server.
Password – enter the password you use to get into SQL
Server.
Document Folder – Enter the path where Beams web will
store the documents (usually in
\\<servername>\c$\inetpub\BeamsCRM\App_Media\
\CompanyDocument )
Domain (Impersonation) – enter the domain for the
impersonation user to use to access the document path
User Name (Impersonation) – enter the username for the
impersonation user to use to access the document path.
Password (Impersonation) – enter the password for the
impersonation user to use to access the document path.

The CRM logon information will be saved as xml file in
C:\Users\<username>\AppData\Roaming\Metisc\MiSync Personal

MiSync Personal User Guide for CRM
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Using MiSync Personal for Beams

Starting MiSync Personal for Beams
To open MiSync Personal for Beams, select:
Start>All Programs>Metisc>MiSync Personal>MiSync
Personal
Alternatively, click on the MiSync Personal icon on your
desktop. The following screen will appear:

MiSync Personal for Beams will automatically log on to
your Outlook or Outlook/Exchange system using either the
default profile of the currently logged-on Windows user, or
your selected profile if you have multiple profiles.
Once you have logged on, you can begin synchronizing
information between Outlook and Beams CRM. The
sections that follow provide details about using MiSync
Personal for Beams.
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MiSync Personal for Beams Basics
This is the main MiSync Personal for Beams screen:

These are the available menus of the main screen:
File>New

A new ‘Leads’ window will open.
File>Exit

MiSync will be closed.
Window>Cascade

Arranges multiple ‘Contacts’ windows.
Window>Tile>Horizontal
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Arranges multiple ‘Contacts’ windows horizontally.
Window>Tile>Vertical

Arranges multiple ‘Contacts’ windows vertically.
Help>Contents

An application help window will open.

Help>Email Support

Send an email to Metisc support.
Help>About…
12  Using MiSync Personal for Beams
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Several sync process are available through the menu
buttons

 Leads
Sync Beams’ Leads into Outlook.
 Tasks
Sync Beams’ Task into Outlook.
Sync Task/Reminder status between both system
 Emails
Sync Outlook Emails into Beams
 Setup
Change setup configuration for Beams and Outlook
system

Synchronizing Leads
This is the main Leads screen of MiSync Personal for
Beams:

MiSync Personal User Guide for CRM
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The Leads icon
allows you to synchronize Outlook
contacts with Beams CRM Name records. You must select
one or more options from each of the three selection areas
before you can synchronize records. The three selection
areas include Synchronize Source, Synchronize Method, and
Synchronize With.

Synchronize Source

This area displays the available Outlook folders. Select the
folder to which you want to add leads and from which you
want to copy leads. Refresh button
will refresh/update
the display of all your Outlook folders.

Synchronize Method

Use the options in this area to specify how you want
MiSync Personal for Beams to synchronize your leads.
Initial Synchronization – Select this option to establish links
between matching record in both Outlook and Beams
CRM. MiSync Personal for Beams matches contacts based
on first name and last name.

Once leads in Outlook and Beams CRM are linked, updates
made in either system can be sent to the other system, or
date based updates can be performed.
►

Note: Due to the way dates are stored in Outlook, your PC’s
regional settings should be correct. If the settings are not
correct, the dates that MiSync compares against in SQL Server
and Exchange may result in incorrect updates and incorrect
data being considered the most recent update.
Add Leads to Outlook – Select this option to add new (not
already linked) contacts in Beams CRM to Outlook
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– Select this option to apply changes
from one system to the other, where the leads records are
already linked. The option “Based on Date last Modified”
allows updates to occur in both systems based on the most
recent update from either system. The option “All” will
update all existing contacts.
Update Existing Contacts

►

Synchronize Options

Note: Due to the way dates are stored in Outlook, your PC’s
regional settings must be correct. If the settings are not correct,
the dates that MiSync compares against in SQL Server and
Exchange may result in incorrect updates and incorrect data
being considered the most recent update.
These options are available only if ‘Add Contacts to
Outlook’ is selected.
Empty selected folder before adding contacts – Select this option if
you want to remove existing Contacts in Outlook. This
option is useful if you are using Folders to store meeting
registrants or Committee Members and the registrants
cancel, or committee members leave. If they are not
deleted, you may have committee members that are not
current.
Add to distribution list: When

this option is selected, it is
possible to create Distribution Lists which include leads
records from Beams CRM that have email address.
Synchronize With

Specify which leads to synchronize with Outlook by
selecting how many days back to look for.

These options are available only if ‘Add Leads to Outlook’
is selected.

MiSync Personal User Guide for CRM
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Synchronize

Synchronize Now

Click this button to synchronize the data
between Outlook and Beams CRM. A progress bar displays
the progress of the operation. When the process is
complete, a message displays informing you of how many
records were synchronized. The synchronize process can be
interrupted/stopped by clicking on the Cancel button which
will appear during synchronization next to the progress bar.
Schedule Synchronization

Schedule the current chosen settings
to run at defined times. This option allows you run
synchronization at set times, for example every Monday
and Friday, every 6 hours, or on the first day of each
month. This option is only available in the E-mail and
Contacts window. For more information see the sections
Scheduling Synchronization.
Open contacts on startup – Tick this check box for MiSync to
start with a ‘Leads’ window. Un-tick this check box and
MiSync Personal for Beams will start without the ‘Leads’
window.

Field Mapping
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CRM fields

Outlook fields

Name

First

Name

Middle

Name

Last

AccountName

CompanyName

Phone Home

Home Phone

Phone Work

Business Phone

Fax

Business Fax

Mobile

Mobile Phone

Email

Email Address

Birth Date

Birthday

Address Primary

Business Address Street

City Primary

Business Address City

State Primary

Business Address State

Zip Code Primary

Business Address Postal Code

Country Primary

Business Address Country

Address Secondary

Other Address Street

City Secondary

Other Address City

MiSync Personal User Guide for CRM

MiSync Personal User Guide for CRM

State Secondary

Other Address State

Zip Code Secondary

Other Address Postal Code

Country Secondary

Other Address Country
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Synchronizing Tasks
This is the main Tasks screen of MiSync Personal for
Beams:

You must select one or more options from each of the three
selection areas before you can synchronize records. The
three selection areas include Synchronize Source, Synchronize
Method, and Synchronize With.
Synchronize Source

This area displays the available Outlook folders. Select the
folder to which you want to add tasks. Refresh button
will refresh/update the display of all your Outlook folders.

Synchronize Method

Use the options in this area to specify how you want
MiSync Personal for Beams to synchronize your tasks.
– Select this option to add new tasks in
Beams CRM to Outlook.
Add Tasks to Outlook

– Select this option to update changes
from Beams to Outlook. The option “Based on Date last
Modified” allows updates to occur in both systems based
on the most recent update from either system. The option
“All” will update all existing tasks.
Update Existing Tasks
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►

Synchronize Options

Note: Due to the way dates are stored in Outlook, your PC’s
regional settings must be correct. If the settings are not correct,
the dates that MiSync compares against in SQL Server and
Exchange may result in incorrect updates and incorrect data
being considered the most recent update.
These options are available only if ‘Add Tasks to Outlook’
is selected.
– Select this option if
you want to add Beams CRM Tasks to Outlook. The system
will empty the Outlook folder and then add all the selected
Beams CRM Tasks.
Empty selected folder before adding tasks

Synchronize With

Specify which tasks to synchronize with Outlook by
selecting from all the available searches. Click ‘New
Advanced Find’ to create a new search in Beams CRM.
Click the Refresh button to refresh/update the display of all
your searches.

These options are available only if ‘Add Tasks to Outlook’
is selected.
Synchronize

Synchronize Now

Click this button to synchronize the data
between Outlook and Beams CRM. A progress bar displays
the progress of the operation. When the process is
complete, a message displays informing you of how many
records were synchronized. The synchronize process can be
interrupted/stopped by clicking on the Cancel button which
will appear during synchronization next to the progress bar.
Schedule Synchronization

Schedule the current chosen settings
to run at defined times. This option allows you run
synchronization at set times, for example every Monday
and Friday, every 6 hours, or on the first day of each
month. For more information see the sections Scheduling
Synchronization.

MiSync Personal User Guide for CRM
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Field Mapping

CRM fields

Outlook fields

Title

Subject

Detail

Body

Time

Start Date

Time

Due Date

Schedule Synchronization
MiSync gives you the ability to schedule Leads and Tasks
synchronizations using the Windows scheduler. First select
the type of Synchronization as you would normally and
then press the Schedule Synchronization button. You will be
presented with a ‘Scheduler’ screen which allows you to
choose the recurrence type of the schedule. Click Next >
to continue.



When scheduling tasks you have three different types of
recursion:
Daily



Weekly



Monthly



Once
Each has its own set of parameters that must be set for the
schedule to be constructed. Pick an option and enter a name
for the task. Click Next > to continue.
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Daily

The first option is ‘Daily’. This allows you to schedule
synchronizations for every ‘x’ number of minutes or hours
on a specific day or days. To schedule this type simply
enter the start time and start date you wish the schedule to
kick off, and tick the option you wish it to recur on.
Weekly
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The second option is ‘Weekly’. This allows you to schedule
synchronizations for every ‘x’ number of weeks on a
specific day or days and at a specified time. To schedule
this type simply enter the start time you wish the schedule
to kick off, enter the weeks you wish it to recur on and tick
the day or days you wish the synchronization to run on.
Monthly

The third option is ‘Monthly’. This allows you to schedule
synchronizations on the ‘x’th day of specific month or
months and at a specified time. To schedule this type
simply enter the start time and day of the month you wish
the schedule to kick off, and tick the month or months you
wish the synchronization to run on.
Once

The final option is ‘Once’. This allows you to schedule
synchronizations just once for a specific time and day. To
schedule this type simply enter the time and day on which
you wish the schedule to kick off.
Once you adjust your schedule, click
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This final screen requires your Windows name and
password. You can enter another user’s name and password
so that the schedule will run as if it were started by that
user. When you are satisfied with your options, click the
Next > button to complete your schedule.

You schedule is now set, click the Finish button to close
the window.

You can view and makes changes to your scheduled tasks
in the Windows Scheduler by going to Start > All
Programs > Accessories > System Tools > Schedule
Tasks
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Synchronizing Emails
This is the main Emails screen of MiSync Personal for
Beams:

This allows you to synchronize Outlook emails to Beams
CRM. The emails in Beams will be related to Leads
records.
Filter Options

The keyword can be used to filter out which emails that
will not be synchronized. If the keyword exist in the
Subject of the Outlook email, it will not by synchronized.
Days in the Past can be used to filter email that sent on
how many days before.

Synchronize

Synchronize Now

Click this button to synchronize the data
between Outlook and Beams CRM. A progress bar displays
the progress of the operation. When the process is
complete, a message displays informing you of how many
records were synchronized. The synchronize process can be
interrupted/stopped by clicking on the Cancel button which
will appear during synchronization next to the progress bar.
Schedule Synchronization

Schedule the current chosen settings
to run at defined times. This option allows you run
synchronization at set times, for example every Monday
and Friday, every 6 hours, or on the first day of each
month. For more information see the sections Scheduling
Synchronization.
Field Mapping
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CRM fields

Outlook fields

Subject

Subject

Description

Body

From Email

Sender

To Email

Email

Sent On

Sent On
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MiSync Personal communicates with Outlook using:
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MAPI



Outlook Object Model
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Appendices

Using Command-Line Parameters
Using command-line parameters allows you to automate
some operations in MiSync. The automation is normally
performed using the Windows Scheduler.
At the command line, type the path of the MiSync
executable, followed by your Beams CRM
user name and password, the command line options.

Frequently Asked Questions
Q. MiSync gives me a message saying the evaluation
period has expired.
A. If this message appears, contact your reseller to obtain a
new serial number.
Q. A new version of Beams CRM has been installed. Do I
need to do anything to MiSync?
A. No, as the database has not changed, MiSync is not
affected at all.
Q. Where can I find the log files?
A. You can find it in
“C:\Users\<username>\AppData\Roaming\Metisc\MiSync
Personal\LogFiles”
Q. Why does my folder not exist in the folder tree
A. Make sure that the parent’s folder is also defined as the
same type (e.g. folder is for contact items than parent also
need to be defined for contact items)
Q. Where is my embedded message attachment ?
A. MiSync currently doesn’t sync embedded message
MiSync Personal User Guide for CRM
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Known Issues
Outlook Connection
 Cannot connect to different Outlook with different
username than what is installed in current computer
 There are occasions of unable to open Outlook after
Synchronisation process and closing Outlook

Installation Notes
This section is provided for users who have installed
MiSync Personal version 4.0.1.1 or above.
To un-install MiSync Personal
1. Make sure that Microsoft Outlook is not running prior to uninstalling.

Open the Contol Panel (under Start -> Settings).
Select the Add Remove Programs icon.
Find the entry for MiSync & select.
Click on the Remove button.

Software License
This is an agreement between you, the end user, and Metisc
Computer Services (MCS). By using this software, you are
agreeing to become bound by the terms of this agreement.
IF YOU DO NOT AGREE TO THE TERMS OF THIS
AGREEMENT, DO NOT USE THIS SOFTWARE.
PROMPTLY REMOVE IT FROM YOUR COMPUTER.
Grant of License
MCS, as Licensor, grants to you, the Licensee, a nonexclusive right to use this software program (hereinafter the
“Software”) in accordance with the terms contained in this
License. You may use the Software on a single computer.
Ownership of Software
MCS retains the copyright, title, and ownership of the
Software and the written materials regardless of the form or
media in or on which the original and other copies may
exist. You may make one copy of the Software solely for
backup purposes. You must reproduce and include the
copyright notice on the backup copy.
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Transfers
You may physically transfer the Software from one of your
computers to another provided that the Software is used on
only one computer at a time.
Term
This License is effective following the date you purchased
the Software. This License will terminate automatically
without notice from MCS if you fail to comply with any
provision of this License. Upon termination you shall
destroy the written materials and all copies of the Software.
Restricted Rights
The Software and any accompanying materials are
provided with Restricted Rights.

Limited Warranty
Metisc Computer Services (MCS) warrants the media on
which the Software is furnished to be free of defects in
material and workmanship, under normal use, for a period
of thirty (30) days following the date of delivery to you. In
the event of defects, MCS's sole liability shall be to replace
the defective media, which has been returned to MCS or
the supplier with your dated invoice and is shown to be
defective. In the event that MCS is unable to replace
defective media, MCS shall refund your money upon your
termination of this License.
The above is the only warranty of any kind, either express
or implied, including but not limited to the implied
warranties of merchantability and fitness for a particular
purpose, that is made by MCS, on this MCS product. No
oral or written information or advice given by MCS, it's
dealers, distributors, agents or employees shall create a
warranty or in any way increase the scope of this warranty
and you may not rely on any such information or advice.
You may have other rights, which vary from state to state.

MiSync Personal User Guide for CRM
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This Software and accompanying documentation
(including instructions for use) are provided "as is" without
warranty of any kind. Further, MCS does not warrant,
guarantee, or make any representations regarding the use,
or the results of use, of the Software or documentation in
terms of correctness, accuracy, reliability, current-ness, or
otherwise. You assume the entire risk as to the results and
performance of the Software. If the Software or written
materials are defective you, and not MCS or its dealers,
distributors, agents, or employees, assume the entire cost of
all necessary servicing, repair or correction.
Neither MCS nor anyone else who has been involved in the
creation, production or delivery of this product shall be
liable for any direct, indirect, consequential or incidental
damages (including damages for loss of business profits,
business interruption, loss of business information, and the
like) arising out of the use or inability to use such product
even if MCS has been advised of the possibility of such
damages.
Should any other warranties be found to exist, such
warranties shall be limited in duration to thirty (30) days
following the date of delivery to you. In no event will
MCS's liability for any damages to you or any other person
exceed the amount paid for the license to use the Software.
This License shall be governed and construed in
accordance with the laws of the State of Western Australia
and shall benefit MCS, its successors and assigns.
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