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Getting Started

Overview
MiSync Personal for iMIS is a tool that allows you to
synchronize contacts between Outlook and iMIS.
You can synchronize contacts based on the following
methods:


iMIS ID



Member Type



Adhoc search



Committee members



Meeting registrants
Once you synchronize data, MiSync stores a link between
iMIS and Outlook so that changes made to contacts in one
system are reflected in the other.

What’s New
Change the separator in IMISAllGroups file to make it
unique.
Former releases:
Add Licensing
Adding Ignore Activity Date checkbox for ignoring from
and thru date in Activity/Committee filtering when
retrieving from iMIS.
Fix Address not updated when sync from Outlook to iMIS.
Fix new Contact from Outlook cannot be search by name in
iMIS.
New User Interface implemented consistent with Outlook
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Choice of MAPI or the Outlook Object Model to
communicate with Outlook has been simplified and
automated
MiSync installed as a separate program group
New security additions for Outlook security
Corrected occasional configurations where e-mail was not
synced from iMIS
Additional Contact fields added to Outlook
Support for multiple e-mail addresses and preferred e-mail
address added
Redundant Verify option removed from Contacts
User information screen allows ID’s to be linked to iMIS
user names, enabling synchronizing for Appointments,
Tasks, E-mails and Opportunity Management
Added alternate CDO processing method where
appropriate
Corrected faults in some Outlook/Exchange configurations
Ability to stop Business Fax numbers coming into Outlook
Manual has been improved
Ability to schedule Contact sync using Windows Scheduler
Ability to create Distribution Lists during Contact sync
from iMIS
MiSync now checks for and ignores any instances where an
email address matches more than one iMIS customer record
Cell phone mapping is now customizable. Users can
choose which ‘name’ table they wish to retrieve a
customer’s cell phone number from when doing a sync
from iMIS to Outlook
MiSync can now handle the third address line, present in
iMIS v10.6 onwards
Users can choose to display company name in the title of
an Outlook contact
Re-enable Bulk Sync synchronization process.

System Requirements
Microsoft SQL Server or MSDE
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iMIS 10.6 and greater for MSDE, or MS SQL
Pentium processor
256 Mb of memory
15 inch color VGA display (17 inch SVGA recommended)
Microsoft Outlook 2000/XP/2003/2007/2010
Microsoft Exchange 2007

Technical Support
For technical support, contact:
Metisc Computer Services
www.metisc.com.au
support@metisc.com.au
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Installing MiSync Personal for iMIS
Before running the installer, please make sure you uninstall
any MiSync Personal installation in your computer.
Run the installation program on the computer on which you
wish to use MiSync. Click Next > to begin the
installation.

Choose the location you wish to install to and specify who
will have access to the program. Then click Next > to
continue the installation.
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MiSync is now ready to be installed. If you are happy with
your installation settings, click Next > to commence the
installation.

Once installation is complete, click
installation process.
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Close

to end the
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There should now be two shortcuts to MiSync Personal
placed on your desktop, one for MiSync Personal for CRM
and one for MiSync Personal for iMIS.

►

To un-install, see “Installation Notes” section in the
appendices.

Running MiSync Personal for iMIS for the First Time
1. Please make sure that your Outlook is connected into any
mailbox.
2. The first time you run MiSync, you may be prompted with
agreement of using Outlook Redemption, check I Agree
and click Ok button.
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3. After that, you are prompted with a database login window.
You will see this window every time you run MiSync. Enter
a valid server address, database name, user name and
password. Click the OK button to login.

4. To change the Data Source, click Select Data Source .

Trial and Registration
First tme user will be prompted by a trial form. We can still
use the application within 30 days after first installation.

MiSync Personal User Guide for iMIS
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Registration can be done by clicking the “Register Now”
button and will prompt for serial number. After doing a
valid registration, these forms will not show up again.
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Starting MiSync Personal for iMIS
To open MiSync, select:
Start>All Programs>Metisc>MiSync>MiSync For Imis
Alternatively, click on the MiSync For iMIS icon on your
desktop. Once you log in, the following screen will appear:

MiSync will automatically log on to your Outlook or
Outlook/Exchange system using either the default profile of
the currently logged-on Windows user, or your selected
profile if you have multiple profiles.
Once you have logged on, you can begin synchronizing
information between Outlook and iMIS. The sections that
follow provide details about using MiSync.
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MiSync Personal for iMIS Basics
This is the main MiSync screen:

These are the available menus of the main screen:
File>New

A new ‘Contacts’ window will open.
File>Exit

MiSync will be closed.
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Preferences

This will open a ‘Preferences’ screen.
The following options are available in the ‘Preferences’
screen:

Cell Phone Mapping to Imis (For All Users)
Tick the Use Custom Cell Phone Mapping check box to
allow synchronization of mobile phone numbers. A valid
database table and field name must also be entered defining
where MiSync should retrieve a contact’s cell phone
number from.
Un-tick the Use Custom Cell Phone Mapping check box to
disallow synchronization of mobile phone numbers.
Outlook Address Defaults
Change address mapping between iMIS and Outlook.
Outlook Options (For All Users)
Tick the Include Fax Number in Synchronization checkbox
to include contact’s fax numbers in Outlook.
Un-tick the Include Fax Number in Synchronization
checkbox to exclude contact’s fax numbers in Outlook.
MiSync Personal User Guide for iMIS

Using MiSync Personal for iMIS  15

Tick the Include Title in Synchronization checkbox to
include titles of contacts (i.e. Mr. Mrs.) in Outlook.
Un-tick the Include Title in Synchronization checkbox to
exclude titles of contacts in Outlook.
Contact File As will display the following options:

Pick an option which will determine how contacts are
sorted in Outlook.
Window>Cascade

Arranges multiple ‘Contacts’ windows.
Window>Tile>Horizontal

Arranges multiple ‘Contacts’ windows horizontally.
Window>Tile>Vertical

Arranges multiple ‘Contacts’ windows vertically.
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Help>Contents

An application help window will open.
Help>Email Support

Send an email to Metisc support.
Help>About…

Display information regarding MiSync and contact
information.
Contacts button

A new ‘Contacts’ window will open.

Synchronizing Contacts
This is the main Contacts screen of MiSync:
MiSync Personal User Guide for iMIS

Using MiSync Personal for iMIS  17

The Contacts icon
allows you to synchronize Outlook
contacts with iMIS Name records. You must select one or
more options from each of the three selection areas before
you can synchronize records. The three selection areas
include Synchronize Source, Synchronize Method, and Synchronize
With.
►

Synchronize Source

Note: Please make sure that the First Name and Last Name in
Outlook is filled before sync to iMIS, because it’s mandatory in
iMIS.
This area displays the available Outlook folders. Select the
folder to which you want to add contacts and from which
you want to copy contacts. Refresh button
will
refresh/update the display of all your Outlook files.

Synchronize Method
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Use the options in this area to specify how you want
MiSync to synchronize your contacts.
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– Select this option to establish links
between matching record in both Outlook and iMIS.
MiSync matches contacts based on first name and last
name.
Initial Synchronization

Once contacts in Outlook and iMIS are linked, updates
made in either system can be sent to the other system, or
date based updates can be performed.
►

Note: Due to the way dates are stored in Outlook, your PC’s
regional settings should be correct. If the settings are not
correct, the dates that iSync compares against in SQL Server
and Exchange may result in incorrect updates and incorrect
data being considered the most recent update.
Add Contacts to Outlook – Select this option to add new (not
already linked) contacts in iMIS to Outlook.

– Select this option to apply changes
from one system to the other, where the contact records are
already linked. The option “Based on Date last Modified”
allows updates to occur in both systems based on the most
recent update from either system. The option “All” will
update all existing contacts.
Update Existing Contacts

The “Based on Date last Modified” and “All” option will
sync from iMIS to Outlook, the “From Outlook to iMIS”
option will sync all from Outlook to iMIS.
►

Note: Due to the way dates are stored in Outlook, your PC’s
regional settings must be correct. If the settings are not correct,
the dates that iSync compares against in SQL Server and
Exchange may result in incorrect updates and incorrect data
being considered the most recent update.
Add Contacts to iMIS – Select this option to add new (not
already linked) contacts in Outlook to iMIS.

MiSync Personal User Guide for iMIS
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Synchronize Options

These options are available only if ‘Add Contacts to
Outlook’ is selected.
Empty selected folder before adding contacts – Select this option if
you want to add iMIS contacts to Outlook. The system will
empty the Outlook folder and then add all the selected iMIS
contacts. This option is useful if you are using Folders to
store meeting registrants or Committee Members and the
registrants cancel, or committee members leave. If they are
not deleted, you may have committee members that are not
current.
Add to distribution list: When this option is selected, it is
possible to create Distribution Lists which include contact
records from iMIS.
Bulk load : When this option is selected, distribution list are
created for all the different groups and contacts are added
to the distribution list. This option also removes contacts
from the distribution list when it is no longer in its
associated IMIS group

Synchronize With

Use the options in this area to specify which contacts to
synchronize with Outlook.

All iMIS Name records

– Select this option to synchronize all

iMIS contacts.
iMIS ID

– Select this option to synchronize one iMIS contact.

– The option value is from all customer
type in iMIS. Select this option to synchronize all iMIS
contacts of the selected member type.
iMIS Member Type

– Select this option to synchronize all iMIS
contacts returned in the selected adhoc search. Note
searches that include iMIS calculations are not supported.
iMIS Adhoc Search
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– The option value is from Committee codes
that’s being used in the activity in iMIS. Select this option
to synchronize all iMIS contacts in the selected committee.
The “Ignore Activity Date” checkbox is used if want to
synchronized all selected Committee without filtering by
From and Thru Date.
iMIS Committee

– The option value is from all event in iMIS.
Select this option to synchronize all iMIS contacts
registered for the selected meeting. The “Include
Cancelled” checkbox is used if cancelled registrants need to
also be synchronized.
iMIS Meeting

Synchronize

Synchronize Now

Click this button to synchronize the data
between Outlook and iMIS. A progress bar displays the
progress of the operation. When the process is complete, a
message displays informing you of how many records were
synchronized. The synchronize process can be
interrupted/stopped by clicking on the Cancel button which
will appear during synchronization next to the progress bar.
Schedule Synchronization

Schedule the current chosen settings
to run at defined times. This option allows you run
synchronization at set times, for example every Monday
and Friday, every 6 hours, or on the first day of each
month. This option is only available in the E-mail and
Contacts window. For more information see the sections
Scheduling Synchronization.
– Tick this check box for MiSync to
start with a ‘Contacts’ window. Un-tick this check box and
MiSync will start without the ‘Contacts’ window.
Open contacts on startup

Schedule Synchronization
MiSync gives you the ability to schedule Contact and
Account synchronizations using the Windows scheduler.
First select the type of Synchronization as you would
normally and then press the Schedule Synchronization button.
You will be presented with a ‘Scheduler’ screen which
allows you to choose the recurrence type of the schedule.

MiSync Personal User Guide for iMIS
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Click

Next >

to continue.

When scheduling tasks you have three different types of
recursion:


Daily



Weekly



Monthly



Once
Each has its own set of parameters that must be set for the
schedule to be constructed. Pick an option and enter a name
for the task. Click Next > to continue.
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Daily

The first option is ‘Daily’. This allows you to schedule
synchronizations for every ‘x’ number of minutes or hours
on a specific day or days. To schedule this type simply
enter the start time and start date you wish the schedule to
kick off, and tick the option you wish it to recur on.
Weekly

The second option is ‘Weekly’. This allows you to schedule
synchronizations for every ‘x’ number of weeks on a
specific day or days and at a specified time. To schedule
this type simply enter the start time you wish the schedule
to kick off, enter the weeks you wish it to recur on and tick
the day or days you wish the synchronization to run on.

MiSync Personal User Guide for iMIS
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Monthly

The third option is ‘Monthly’. This allows you to schedule
synchronizations on the ‘x’th day of specific month or
months and at a specified time. To schedule this type
simply enter the start time and day of the month you wish
the schedule to kick off, and tick the month or months you
wish the synchronization to run on.
Once

The final option is ‘Once’. This allows you to schedule
synchronizations just once for a specific time and day. To
schedule this type simply enter the time and day on which
you wish the schedule to kick off.
Once you adjust your schedule, click

Next > .

This final screen requires your Windows name and
password. You can enter another user’s name and password
so that the schedule will run as if it were started by that
user. When you are satisfied with your options, click the
Next > button to complete your schedule.
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You schedule is now set, click the Finish button to close
the window.

You can view and makes changes to your scheduled tasks
in the Windows Scheduler by going to Start > All
Programs > Accessories > System Tools > Schedule
Tasks
Bulk Load
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When creating the Schedule Synchronization with Bulk
Load, the application will create a new file named
(username)IMISAllGroups in the
"C:\Users\(username)\AppData\Roaming\Metisc\MiSync
Personal”, this file contains of all groups name (separated
by unique character “!@#”) from Member Type, Adhoc,
Committee, and Meeting that want to be synchronize when
scheduler is running with the Group type at the prefix.
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You can modified this file to only leave the group that want
to be synchronize, for example if you only want to sync the
ADHOC group, just delete all groups that don’t has
ADHOC prefix, and run the scheduler. Need to remember
that everytime you create a new Bulk Load scheduler, this
file is refreshed and will contains all groups again.

Communicating with Outlook
MiSync communicates with Outlook using:
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MAPI



Outlook Object Model
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Using Command-Line Parameters
Using command-line parameters allows you to automate
some operations in MiSync. The automation is normally
performed using the Windows Scheduler, or Automation
products like iFlow for iMIS.
At the command line, type the path of the MiSync
executable, followed by your iMIS user name and
password, the command line options.
Example Contacts Command-line Sync:
MiSync.exe iusr:<user> ipwd:<password> /close
/OLPROFILE:<profile name>
/SYNCITEM:<item>
/SYNCFOLDER:<folder name>
/SYNCDIR:<method>,<direction>[,EMPTY]
/SYNCMETHOD:<type>[=<name>]

Where:
<profile name> = Name of Outlook Profile
<item> = CONTACTS
<folder name> = Name of Outlook folder
<method> = EXISTING or NEW
<direction> = TOMAPI, FROMMAPI, BOTH
<type> = ALL, or
IFS=<IFS filename>, or
TYPE=<member type>, or
ADHOC=<adhoc searchname>, or
COMMITTEE=<committee name>, or
MEETING=<meeting code>

Example E-mail Command-line Sync:
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MiSync.exe iusr:<user> ipwd:<password> /close
/OLPROFILE:<profile name>
/SYNCITEM:<item>
/SYNCFOLDER:<folder name>
Where:
<profile name> = Name of Outlook Profile
<item> = EMAIL
<folder name> = Name of Outlook folder

Connection and command line options can be preceded by
“-“ or “/.” These options are listed below. To execute more
than one synch in the same run, precede each task with the
SYNCITEM: command.
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Connection
DSN:<datasource name>

iMIS datasource name

USR:<username>

Database admin username

PWD:<password>

Database admin password

IUSR:<username>

iMIS username

IPWD:<password>

iMIS password

Commands
CLOSE

Closes the MiSync window when done

SYNCFOLDER:<folder name>

Name of Outlook folder

SYNCDIR:<method>,<direction>

EXISTING or NEW

SYNCITEM:<item> Currently Only supports ‘Contacts’ and ‘Email'
[,EMPTY]

Clear the folder first

SYNCMETHOD:<type>[=<name>]

ALL or
IFS=<IFS filename> or
TYPE=<member type> or
ADHOC=<adhoc search name>
COMMITTEE=<committee name> or
MEETING=<meeting code>

DISTNAME:<name>

Name of Distribution group to add
Contacts to. GAL only.

DISTEMPTY

Empty the Distribution group

before
Adding the contacts. GAL
only
ORGNAME:<name>

Name of Organizational unit to add
Contacts to. GAL only.

DEBUG

MiSync Personal User Guide for iMIS

Debugging Mode.
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Frequently Asked Questions
Q. MiSync gives me a message saying the evaluation
period has expired.
A. If this message appears, contact your reseller to obtain a
new serial number.
Q. A new version of iMIS has been installed. Do I need to
do anything to MiSync?
A. No, as the database has not changed, MiSync is not
affected at all.
Q. Where can I find the log files?
A. You can find it in
“C:\Users\<username>\AppData\Roaming\Metisc\MiSync
Personal\LogFiles”

Installation Notes
This section is provided for users who have installed
MiSync version 3.0.0.0 and above.
To un-install MiSync
1. Make sure that Microsoft Outlook is not running prior to uninstalling.

5. Open the Contol Panel (under Start -> Settings).
6. Select the Add Remove Programs icon.
7. Find the entry for MiSync & select.
8. Click on the Remove button.

Software License
This is an agreement between you, the end user, and Metisc
Computer Services (MCS). By using this software, you are
agreeing to become bound by the terms of this agreement.
IF YOU DO NOT AGREE TO THE TERMS OF THIS
AGREEMENT, DO NOT USE THIS SOFTWARE.
PROMPTLY REMOVE IT FROM YOUR COMPUTER.
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Grant of License
MCS, as Licensor, grants to you, the Licensee, a nonexclusive right to use this software program (hereinafter the
“Software”) in accordance with the terms contained in this
License. You may use the Software on a single computer.
Ownership of Software
MCS retains the copyright, title, and ownership of the
Software and the written materials regardless of the form or
media in or on which the original and other copies may
exist. You may make one copy of the Software solely for
backup purposes. You must reproduce and include the
copyright notice on the backup copy.
Transfers
You may physically transfer the Software from one of your
computers to another provided that the Software is used on
only one computer at a time.
Term
This License is effective following the date you purchased
the Software. This License will terminate automatically
without notice from MCS if you fail to comply with any
provision of this License. Upon termination you shall
destroy the written materials and all copies of the Software.
Restricted Rights
The Software and any accompanying materials are
provided with Restricted Rights.

Limited Warranty
Metisc Computer Services (MCS) warrants the media on
which the Software is furnished to be free of defects in
material and workmanship, under normal use, for a period
of thirty (30) days following the date of delivery to you. In
the event of defects, MCS's sole liability shall be to replace
the defective media, which has been returned to MCS or
the supplier with your dated invoice and is shown to be
defective. In the event that MCS is unable to replace
defective media, MCS shall refund your money upon your
termination of this License.
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The above is the only warranty of any kind, either express
or implied, including but not limited to the implied
warranties of merchantability and fitness for a particular
purpose, that is made by MCS, on this MCS product. No
oral or written information or advice given by MCS, it's
dealers, distributors, agents or employees shall create a
warranty or in any way increase the scope of this warranty
and you may not rely on any such information or advice.
You may have other rights, which vary from state to state.
This Software and accompanying documentation
(including instructions for use) are provided "as is" without
warranty of any kind. Further, MCS does not warrant,
guarantee, or make any representations regarding the use,
or the results of use, of the Software or documentation in
terms of correctness, accuracy, reliability, current-ness, or
otherwise. You assume the entire risk as to the results and
performance of the Software. If the Software or written
materials are defective you, and not MCS or its dealers,
distributors, agents, or employees, assume the entire cost of
all necessary servicing, repair or correction.
Neither MCS nor anyone else who has been involved in the
creation, production or delivery of this product shall be
liable for any direct, indirect, consequential or incidental
damages (including damages for loss of business profits,
business interruption, loss of business information, and the
like) arising out of the use or inability to use such product
even if MCS has been advised of the possibility of such
damages.
Should any other warranties be found to exist, such
warranties shall be limited in duration to thirty (30) days
following the date of delivery to you. In no event will
MCS's liability for any damages to you or any other person
exceed the amount paid for the license to use the Software.
This License shall be governed and construed in
accordance with the laws of the State of Western Australia
and shall benefit MCS, its successors and assigns.
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